ERPM 5.4 Email Settings Cannot be Written when using SQL Native Client (11.x ODBC)

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Date: April 15, 2016
Revision: 1.1

Problem:
ERPM 5.4.0 can make use of one of many database providers like previous versions. However, ERPM 5.4.0 also introduced a new email system and moved the email settings into the database to make it available to all ERPM components.

When ERPM is using the SQL Native Client to connect to the primary ERPM datastore, the new email settings cannot be properly written into the database resulting in bad row information in the database and apparent program freezes for short periods of times as well as failure to launch on the first attempt.

Additionally, the following may be logged:

Code:
** Internal warning (EmailSmtpSettings.cpp:1304): HRESULT failed (0x80004005: Unspecified error)
** Internal warning (PropSheet_EmailSettings.cpp:246): HRESULT failed (0x80004005: Unspecified error)

Cause:
The SQL Native Client makes a departure from previous database clients where a data array with a size of 0 bytes causes the SQL Native Client to essentially break during that call. This is not a problem with the SQL OLEDB Provider, only the SQL Native Client (when using either ODBC or OLEDB).

Resolution:
For ERPM v5.4.0, the only resolution is to either write the settings into the database by hand using SQL Management Studio or similar or to switch to using the SQL OLEDB provider when it is needed to write/update the email settings.

For versions post 5.4.0, a code change has been made to change the data value to NULL rather than empty which resolves the issue when using the SQL Native Client.

These updates will be included in the next public release of ERPM.

Applies To:
Enterprise Random Password Manager (ERPM) v5.4.0

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