SSH Key Discovery Fails on New ERPM 5.0.1 Database

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Date: September 10, 2015
Version: 1.0

Problem:

When performing a discovery for accounts and account usage against Linux/UNIX hosts using ERPM 5.0.1 you may see the following errors in the ERPM logs:

Code:
** Internal warning (KeyPairHelper.cpp:497): HRESULT failed (0x80004005: Unspecified error)
** Internal warning (AccountDataStoreOps_Unix.cpp:1487): HRESULT failed (0x80004005: Unspecified error)
** Internal warning (AccountDataStoreOps_Unix.cpp:1243): HRESULT failed (0x80004005: Unspecified error)
** Internal warning (DeferredJobThreadRefreshAll.cpp:1108): HRESULT failed (0x80004005: Unspecified error)

Cause:

The problem exists due to code requiring the ability to write null values to unused tables in the ERPM database. This problems affects installations of ERPM 5.0.1 using a new database. Upgraded instances of ERPM are not affected.

Resolution:

Using your preferred database editing tool such as SQL Management Studio, run the following queries to allow the unused tables to accept null values:

Code:
ALTER TABLE tbl_UserKeys
ALTER COLUMN eCryptoType_Unused int NULL

ALTER TABLE tbl_UserKeys
ALTER COLUMN sSignature_Unused nvarchar(255) NULL

ALTER TABLE tbl_UserKeys
ALTER COLUMN dtDateOfEncryption_Unused datetime NULL

ALTER TABLE tbl_UserKeys
ALTER COLUMN dwCryptType int NULL


ALTER TABLE tbl_UserKeys
ALTER COLUMN sCryptKeyID nvarchar(255) NULL

Applies To:
Enterprise Random Password Manager (ERPM) version 5.0.1

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