AppComponentDeploymentCheckin_Generic Repeatedly Logged

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Date: October 22, 2014
Revision: 1.0

Problem:

A zone processor has started utilizing 100% of the CPU and keeps logging the following message to the service log (PWCJobLog.txt):

Code:
** Internal warning (AppComponentDeploymentCheckin_Generic.cpp:33): HRESULT failed (0x80070002: File not found)
** Internal warning (AppComponentDeploymentCheckin_Generic.cpp:33): HRESULT failed (0x80070002: File not found)
** Internal warning (AppComponentDeploymentCheckin_Generic.cpp:33): HRESULT failed (0x80070002: File not found)
** Internal warning (AppComponentDeploymentCheckin_Generic.cpp:33): HRESULT failed (0x80070002: File not found)
** Internal warning (AppComponentDeploymentCheckin_Generic.cpp:33): HRESULT failed (0x80070002: File not found)

Cause:

This indicates that the zone processor has a recorded deployment GUID (in local registry), but the GUID was not found in the database.

Resolution:

On the zone processor host:

  1. Stop the zone processor. Its name will be RouletteSked$ZONENAME.
  2. Open the registry and navigate to HKLM\Software\WoW6432Node\Lieberman\PWC\PWCZonePro cessor\{ZoneName} and delete ComponentDeploymentGUID.



On the ERPM console:

  1. Open the console
  2. Open the Jobs dialog
  3. Open the Zone Processor dialog
  4. Select the entry or entries for the zone processor host in question and click Delete Registration. This will delete only the ZP registration and not the actual ZP installation or settings.



On the zone processor host:

  1. Start the zone processor. Its name will be RouletteSked$ZONENAME.
  2. Start checking the job log for the errors.



On the ERPM console:

  1. Open the console
  2. Open the Jobs dialog
  3. Open the Zone Processor dialog
  4. Notice that the zone processor has re-registered itself.



Applies To:

  • Enterprise Random Password Manager (ERPM)
  • Random Password Manager (RPM)
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