ERPM Web Site Will Not Allow Users to Login

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Date: September 22. 2015
Revision: 1.1

Problem:

Although web site access delegation permissions are set correctly, no user is able to login to the E/RPM web site. If the user types in their name and password and selects the Login button, they are simply returned to the login page. The E/RPM logs reveal no useful information for troubleshooting.

Cause:

The value for “Force Inactive Web Session timeout (minutes): is set to ‘0’ in the web site application settings. This value will force a logout of a web site user if their account has been inactive for N minutes. If this value is set to ‘0’, the user logs in, is inactive for 0 minutes and is immediately logged out.
This is sometimes seen when upgrading from a much older version of E/RPM to a current version. Older versions of the solution would treat the value of ‘0’ as being an indefinite setting and allow a user to stay logged in without logout, indefinitely.


Resolution:

Set the value for inactive web sessions to any value in minutes other than 0.
In the E/RPM management console select Manage Web App, right-click on the web site | Change Web Application Options for Selected Instance | Yes | Security tab | update the value for Force Inactive Web Session Timeout (minutes).

Applies to:

  • Enterprise Random Password Manager (ERPM)
  • Random Password Manager (RPM)
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